اطلاعیه

بستن
هنوز اطلاعیه ای در دست نیست.

مشکل در نصب پیشنیاز های ari استریسک در linux

بستن
X
 
  • فیلتر کردن
  • زمان
  • نمایش
Clear All
پست های جدید

    مشکل در نصب پیشنیاز های ari استریسک در linux

    سلام
    متاسفانه ایران فلتر است و نمیشه از منبع های لینوکس استفاده کرد.من میخوام برنامه زیر نصب کنم تا بتونم از طریق C# بتونم استریسک کنترل کنم اما نمی تونم پکیج هارو نصب کنم.دستی توی اینترنت یکبار گشتم ولی استریس قبول نکرد.
    https://wiki.asterisk.org/wiki/displ...arted+with+ARI

    شما باشید چطوری نصب می کنید؟

    من اول خواستم کانکشن PPTP درست کنم بعد نصب کنم که اونم باید میرفتم به صورت دستی دانلود میکردم بعد نصبش میکردم اما بازم نشد.هرچی پیدا میکردم و میخواستم نصب کنم خطا می داد.

    خلاصه نگید resposve های لینوکس اصلاح کن که نشد.
    فایل برای دانلود بدید.
    البته من بیشتر برای الستیکس 2.5 میخوام.
    همین پکیج های این صفحه رو کم بدید ممنون میشم.
    الستیکس 2.5 32 بیتی

    #2
    الان شما چیو نتونستی نصب کنی؟ npm ؟!!!
    Instagram : https://www.instagram.com/iranlinuxforum

    Voip Trainer - Asterisk - Elastix - Agi Programming- NewRock

    Voip Expert :ASTERISK-ELASTIX-NewRock Certified-With Experience of Working With
    Sangoma-Digium-Openvox-Synway-Atcom-Quintum Tenor-Polycom-Yealink-Rtx-Snom
    Cisco Collaboration - CME-CUCM-CUPs-CUC-WEBEX
    LPI ( Fundamental - LPI1 and LPI2 ) - Monitoring: ZABBIX-VOIPMONITOR-NAGIOS - CCNA

    Linkedin Profile : https://www.linkedin.com/in/masuma-vahid-26b17b66/

    کامنت


      #3
      همون مواردی که اول صفحه نوشته و گفته با این ها شروع کنیم
      و نصب کرده مثالا

      1. If you don't have it already, install npm
        $ apt-get install npm



      2. Install the ws node package:
        $ npm install -g wscat




      Getting curl

      In order to control a channel in the Stasis dialplan application through ARI, we also need an HTTP client. For the sake of this example, we'll use curl:
      $ apt-get install curl

      کامنت


        #4
        خوب شما سورس فایلش رو دانلود و نصب کنید. لینک زیر رو مطالعه بفرمایید:
        install Node JS and NPM on CentOS
        Instagram : https://www.instagram.com/iranlinuxforum

        Voip Trainer - Asterisk - Elastix - Agi Programming- NewRock

        Voip Expert :ASTERISK-ELASTIX-NewRock Certified-With Experience of Working With
        Sangoma-Digium-Openvox-Synway-Atcom-Quintum Tenor-Polycom-Yealink-Rtx-Snom
        Cisco Collaboration - CME-CUCM-CUPs-CUC-WEBEX
        LPI ( Fundamental - LPI1 and LPI2 ) - Monitoring: ZABBIX-VOIPMONITOR-NAGIOS - CCNA

        Linkedin Profile : https://www.linkedin.com/in/masuma-vahid-26b17b66/

        کامنت


          #5
          البته فک کنم تو ریپازیتوریه epel سنت او اس 6 به بالا باشه تست کنید:
          کد PHP:
          sudo yum install epel-release
          sudo yum install nodejs
          sudo yum install npm 
          Instagram : https://www.instagram.com/iranlinuxforum

          Voip Trainer - Asterisk - Elastix - Agi Programming- NewRock

          Voip Expert :ASTERISK-ELASTIX-NewRock Certified-With Experience of Working With
          Sangoma-Digium-Openvox-Synway-Atcom-Quintum Tenor-Polycom-Yealink-Rtx-Snom
          Cisco Collaboration - CME-CUCM-CUPs-CUC-WEBEX
          LPI ( Fundamental - LPI1 and LPI2 ) - Monitoring: ZABBIX-VOIPMONITOR-NAGIOS - CCNA

          Linkedin Profile : https://www.linkedin.com/in/masuma-vahid-26b17b66/

          کامنت


            #6
            سلام.ممنون بابت راهنماییتون ولی نشد.
            فکر کنم CentOS 5.5 نصب هست برای من.البته همونیه که الستیکس 2.5 روشه.
            شما چشوری این پکیج هارو دانلود و نصب می کنید؟

            کامنت


              #7
              خوب پس سورسش رو دانلود و نصب کنید. من اینجور مواقع از طریق سورس نصب میکنم که دیگه مهم نیست سنت او اس باشه یا اوبونتو و یا ورژنش چی باشه
              همون لینک که دادم رو مطالعه بفرمایید.
              Instagram : https://www.instagram.com/iranlinuxforum

              Voip Trainer - Asterisk - Elastix - Agi Programming- NewRock

              Voip Expert :ASTERISK-ELASTIX-NewRock Certified-With Experience of Working With
              Sangoma-Digium-Openvox-Synway-Atcom-Quintum Tenor-Polycom-Yealink-Rtx-Snom
              Cisco Collaboration - CME-CUCM-CUPs-CUC-WEBEX
              LPI ( Fundamental - LPI1 and LPI2 ) - Monitoring: ZABBIX-VOIPMONITOR-NAGIOS - CCNA

              Linkedin Profile : https://www.linkedin.com/in/masuma-vahid-26b17b66/

              کامنت


                #8
                این خطارو میده زمان نصب دستی بسته.
                ./configure
                من می نویسم و بعدش خطا میده.البته قبلش هم وارد پوشه شدم.
                برای بزرگتر شدن عکس روی آن کلیک کنید

نام:	Node.JPG
نمایش ها:	1
اندازه:	70.6 KB
شناسه:	17149

                کامنت


                  #9
                  نوشته شده توسط abrahim مشاهده پست
                  این خطارو میده زمان نصب دستی بسته.

                  من می نویسم و بعدش خطا میده.البته قبلش هم وارد پوشه شدم.
                  [ATTACH=CONFIG]1773[/ATTACH]
                  این خطا به خاطر به روز نبودن Peython می باشد.که با نصب آن و یا نصب نسخه ی قدیمی تر Nidejs حل میشود.
                  البته من openssl حذف کردم و گفتم نصبش نکن.به دردسرش نمی .....

                  کامنت


                    #10
                    من این nodejs نصب کردم ولی از الآن به بعدش دیگه نمی دونم چطوری npm نصب کنم.من نسخه های مختلف npm از سایت زیر دانلود کردم اما همشون خطا می دن و نیاز به فایل های مختلفی دارن.
                    http://rpmfind.net/linux/rpm2html/search.php?query=npm&submit=Search+...&system=&arc h=


                    آخرشم رفتن از خودت https://github.com/npm/npm دانلود کردم دستور
                    ./configure && make && make install
                    دادم اما بازم نصب نکرد و خطا داد
                    برای بزرگتر شدن عکس روی آن کلیک کنید

نام:	npm.JPG
نمایش ها:	1
اندازه:	75.5 KB
شناسه:	17150

                    کامنت


                      #11
                      سلام پیش نیاز ها رو نصب کردین مثل gcc و ... ؟؟؟
                      والا من که بدون مشکل پیش رفتم:
                      برای بزرگتر شدن عکس روی آن کلیک کنید

نام:	node.png
نمایش ها:	1
اندازه:	127.7 KB
شناسه:	17151

                      شما مشکل dependency دارین
                      Instagram : https://www.instagram.com/iranlinuxforum

                      Voip Trainer - Asterisk - Elastix - Agi Programming- NewRock

                      Voip Expert :ASTERISK-ELASTIX-NewRock Certified-With Experience of Working With
                      Sangoma-Digium-Openvox-Synway-Atcom-Quintum Tenor-Polycom-Yealink-Rtx-Snom
                      Cisco Collaboration - CME-CUCM-CUPs-CUC-WEBEX
                      LPI ( Fundamental - LPI1 and LPI2 ) - Monitoring: ZABBIX-VOIPMONITOR-NAGIOS - CCNA

                      Linkedin Profile : https://www.linkedin.com/in/masuma-vahid-26b17b66/

                      کامنت


                        #12
                        سلام علیکم
                        من از دست این نیازمندی های پشت سر هم خسته شدم.
                        شما چه نسخه ای دارید؟

                        من اومدن این gcc نصب کنم میگه cpp نصب کن و libgcc

                        چه نسخه ای از این الستیکس یا استریسک دانلود کنیم که دردسرش کمتر باشه.واینقدر پکیج نخواد.
                        ممنون

                        کامنت


                          #13
                          نوشته شده توسط Backtrack مشاهده پست
                          سلام پیش نیاز ها رو نصب کردین مثل gcc و ... ؟؟؟
                          والا من که بدون مشکل پیش رفتم:
                          [ATTACH=CONFIG]1777[/ATTACH]

                          شما مشکل dependency دارین
                          شما داری Node نصب میکنی؟؟
                          من از اون رد شدم و دارم npm نصب می کنم.

                          کامنت


                            #14
                            شما بزن :
                            yum install gcc
                            خودش بقیه چیزها رو هم نصب میکنه

                            در مورد سوال دوم ربطی به نسخه نداره به هر حال روی هر نسخه ای که باشید باید پیش نیازهای ari رو نصب کنید
                            خوب استریسک که صرفا یه سرویسه و با خودش پیش نیازهای بالا رو که نصب نمیکنه. سیستم عاملتون باید این پیش نیازها روش نصب باشه
                            Instagram : https://www.instagram.com/iranlinuxforum

                            Voip Trainer - Asterisk - Elastix - Agi Programming- NewRock

                            Voip Expert :ASTERISK-ELASTIX-NewRock Certified-With Experience of Working With
                            Sangoma-Digium-Openvox-Synway-Atcom-Quintum Tenor-Polycom-Yealink-Rtx-Snom
                            Cisco Collaboration - CME-CUCM-CUPs-CUC-WEBEX
                            LPI ( Fundamental - LPI1 and LPI2 ) - Monitoring: ZABBIX-VOIPMONITOR-NAGIOS - CCNA

                            Linkedin Profile : https://www.linkedin.com/in/masuma-vahid-26b17b66/

                            کامنت


                              #15
                              ممنون از راهنمایی تون.(می خواستم فقط تصویر ارسال کنم.ولی نمی شد بدون متن اینکارو کرد)
                              برای بزرگتر شدن عکس روی آن کلیک کنید

نام:	yum install.JPG
نمایش ها:	1
اندازه:	35.8 KB
شناسه:	17153

                              کامنت

                              درباره انجمن منطقه لینوکسی ها

                              انجمن منطقه لینوکسی ها با هدف ارتقاء سطح علمی کاربران در سطح جهانی و همچنین کمک به بالا بردن سطح علمی عمومی در زمینه های تخصصی فوق پایه گذاری شده است. انجمن منطقه لینوکسی ها از طریق کارشناسان و متخصصان پاسخگوی سوالات گوناگون کاربران مبتدی یا پیشرفته میباشد تا حد امکان تلاش شده که محیطی متنوع و کاربر پسند و به دور از هرگونه حاشیه جهت فعالیت کاربران در این انجمن ایجاد شود. لذا ما به صورت مستمر برای پیشرفت کمی و کیفی محتوی و اطلاعات انجمنمان میکوشیم که این برای ما ارزشمند و حائز اهمیت است. کلیه حقوق،اطلاعات و مقالات در این انجمن متعلق به سایت منطقه لینوکسی ها میباشد، و هرگونه نسخه برداری بدون ذکر منبع مورد پیگرد قانونی خواهد شد.

                              شبکه های اجتماعی
                              در حال انجام ...
                              X