اطلاعیه

بستن
No announcement yet.

تفاوت apt-get با aptitude در debian

بستن
X
 
  • فیلتر کردن
  • زمان
  • نمایش
Clear All
پست های جدید

    تفاوت apt-get با aptitude در debian

    سلام به همه
    من برای نصب یه پکیجی دستور apt-get install استفاده کردم ولی پیغام زیر رو بهم داد :
    کد PHP:

    apt
    -get install zabbix-server-mysql zabbix-frontend-php
    Reading package lists
    ... DoneBuilding dependency tree       
    Reading state information
    ... Done
    Some packages could not be installed
    This may mean that you have
    requested an impossible situation 
    or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:


    The following packages have unmet dependencies:
     
    zabbix-server-mysql Dependslibc6 (>= 2.17but 2.13-38+deb7u6 is to be installed
                           Depends
    libsnmp30 (>= 5.7.2~dfsgbut it is not installable
                           Recommends
    mysql-server (>= 4.0.16-2but it is not going to be installed
                           Recommends
    snmpd but it is not going to be installed
                           Recommends
    snmptt but it is not going to be installed
    E
    Unable to correct problemsyou have held broken packages
    ولی وقتی به جای apt-get از دستور aptitude install zabbix-server-mysql استفاده کردم پکیجش به درستی و کامل نصب شد.
    میخواستم بدونم تفاوت این دوتا چی هست و چرا با apt-get نصب نشد و با aptitude نصب شد ؟
    پیشاپیش از راهنمایی شما سپاسگذارم.:263::280:

    #2
    سلام اگر از دید کلی به دو دستور apt-get و aptitude نگاه کنیم در حقیقت هر دوی آنها یک کار را انجام میدهند همونطور که میدانید برای نصب و حذف و کلا مدیریت پکیج های لینوکسی مورد استفاده قرار میگیرد البته یکسری تفاوت های ریزی با هم دارند که استفاده انها را از هم مجازا ساخته مثلا در apt-get اگر نیاز باشه که پکیجی حذف بشه و پکیج جدید جایگزین بشه این کار طی یک کامند و به صورت اتوماتیک انجام نمیشود و نیازمند اجرا کردن دستور دومی هم هست در صورتی که در aptitude پکیج قدیمی حذف و جدید جایگزین خواهد شد تفاوت کامل مشهود این دو کامند در این است که دستور آپتیتود یک کنسول منحصر به فرد برای مدیریت کامل پکیج ها دارد که در آن گزینه های search , install , remove و غیره برای پکیج ها موجود میباشد
    برای بزرگتر شدن عکس روی آن کلیک کنید

نام:	Selection_001.png
نمایش ها:	1
اندازه:	46.2 KB
شناسه:	17109


    تفاوتی که به مشکل شما هم مربوط میشود اینست که وقتی پکیجی را میخواهیم نصب کنیم و این پکیج نیاز به یک dependency دارد که این دیپندنسی در سیستم شما نصب هست منتها با ورژن قدیمی و برای این نصب شما نیاز به ورژن جدید این dependency دارید وقتی با apt-get میخواهید نصب کنید به شما پیغام خطای unmet dependency میدهد و به شما راه حل هم نمیدهد و شما خودتان باید برین دستی پکیج های ورژن قدیمی را حذف و ورژن های جدید را نصب کنید تا مشکل apt-get حل شود و یا میتوانید با دستور apt-get upgrade تمامی پکیج های ورژن قدیمی را به آخرین ورژن موجود آپگرید کنید و سپس پکیج مورد نظرتون را نصب کنید. در حالی که اگر از دستور aptitude استفاده کنید این دستور به صورت هوشمندانه پکیج ورژن قدیم را پیدا کرده و ورژن جدید مورد نیاز را به شما اعلام میکند و برای شما راه حل را نیز ارایه میدهد و از شما میپرسد که ایا با این راه حل موافق هستید و در صورتی که شما yes را انتخاب کنید :
    کد PHP:

    Install the following packages
    :php5-common [5.2.6.dfsg.1-3ubuntu4 (jaunty)]
    Score is 20
    Accept this solution
    ? [Y/n/q/?] 
    تمامی مراحل بالا (حذف dependency ورژن قدیم - نصب dependency ورژن جدید و در نهایت نصب پکیجی که مورد نظر شماست) یکجا انجام میدهد.
    Telegram : https://telegram.me/linuxzone

    voip trainer - Asterisk - Elastix - Agi Programming- NewRock

    Voip Expert :ASTERISK-ELASTIX-NewRock Certified-With Experience of Working With
    Sangoma-Digium-Openvox-Synway-Atcom-Quintum Tenor-Polycom-Yealink-Rtx-Snom
    Cisco Collaboration - CME-CUCM-CUPs-CUC-WEBEX
    LPI ( Fundamental - LPI1 and LPI2 ) - Monitoring: ZABBIX-VOIPMONITOR-NAGIOS - CCNA

    Linkedin Profile : https://www.linkedin.com/in/masuma-vahid-26b17b66/

    کامنت

    درباره انجمن منطقه لینوکسی ها

    انجمن منطقه لینوکسی ها با هدف ارتقاء سطح علمی کاربران در سطح جهانی و همچنین کمک به بالا بردن سطح علمی عمومی در زمینه های تخصصی فوق پایه گذاری شده است. انجمن منطقه لینوکسی ها از طریق کارشناسان و متخصصان پاسخگوی سوالات گوناگون کاربران مبتدی یا پیشرفته میباشد تا حد امکان تلاش شده که محیطی متنوع و کاربر پسند و به دور از هرگونه حاشیه جهت فعالیت کاربران در این انجمن ایجاد شود. لذا ما به صورت مستمر برای پیشرفت کمی و کیفی محتوی و اطلاعات انجمنمان میکوشیم که این برای ما ارزشمند و حائز اهمیت است. کلیه حقوق،اطلاعات و مقالات در این انجمن متعلق به سایت منطقه لینوکسی ها میباشد، و هرگونه نسخه برداری بدون ذکر منبع مورد پیگرد قانونی خواهد شد.

    شبکه های اجتماعی

    ایمیل مدیریت

    Habili@linux-zone.org

    در حال انجام ...
    X